BusinessObjects Board

Unhandled Exception Error C0000005 - how to fix it!

The Unhandled Exception Error (C0000000005) is caused by a number of different things. It seems to be a kind of catch all for those errors that BO doesn’t have a more specific error message for. You can upgrade to higher service packs to get this message less often but it still occurs even within 5.1.5. Here are a number of causes and potential resolutions.

  1. Part of the Business Objects NT profile becoming corrupt.
    Remove the following registry key:

Go to registry key HKEY_CURRENT_SOFTWARE/Software/Business Objects/BusinessObjects/5.0/USERNAME User Prefs

Something under here becomes corrupt. This can happen in many circumstances, but in particular where a low spec machine (e.g. 64Mb - this should ring alarm bells) is trying to open a ‘large’ report - sometimes as little as a couple of Mb. When USERNAME signs on to BO again, the key is recreated with the correct values.

  1. Refreshing a report.
    In fact, the refreshing completes and you see the message ‘Disconnecting…’. This is BO, signing out from the database which it has been getting data from - normally you wouldn’t see this unless BO is going slow. The fact that you see this, then get the bug is again a PC resource problem. Try it on a faster better specified machine to prove this.

Tidy up the report, remove unused variables, formulas as well as objects from the different queries. Encourage the user to purge the report, so when they pick it up next time the PC doesn’t use much resource opening it. Sound them out on scheduling the report and getting the final result sent to them.

  1. Importing universes
    Another reason for C0000005 is a bug specific to the version of BO we have, 5.1.2. This is the problem with importing universes. Basically, each changed version of the universe has a counter which is incremented each time you save and export. Something goes wrong with this counter so BO is not happy to get the new universe. Mostly this is solved by deleting the existing universe from the C:\ drive and then forcing and import. There is a fix (which I have never got to work) which is to import and export twice. Don’t forget about Tools/Universe - you can try and force an import from here. This was supposed to be fixed in 5.1.3.

  2. An old or corrupt dll
    If you look at the information given when you get the unhandled exception error there is a bit of hex and references to a bunch of dlls. Occasionally, one of those dlls is a duff version - try tracking that down. Also, could have problems with duplicate version of dlls, same file, e.g. ociw32.dll in more than one directory.

  3. Miscellaneous resolutions
    Try a full reinstallation of BO. i.e. deinstall, make sure no trace of files, folders and registry entries before reinstalling. Reduce the graphics acceleration level via control panel - not a problem on this site, but worth knowing about.

cheers, Nick

Nick Daniels :uk: (BOB member since 2002-08-15)

BO Deski XI having problems with opening macro
Issues with running an Add-in Macro
Unable to connect BO
Stop report auto refreshing before it crashes....
What privilages do we need to build universe
Unhandled Exception
refresh report bo crash
OLE DB cannot create a connection
anybody gotten 61b reporter/Bca to work on sybase 125?
Error message while using BO!
Unhandled Exception Code: c0000005
Error while importing the universe
(c0000005 Unhandled Error) - When Cutting & Pasting Cell
Error Dump
BO error
Unhandled exception error in BO 6.1.0 when refreshing report
Getting unexpected error
Error while working on Designer
Unhandled Exception Window in BO Full Client
Reporter is very slow, Designer and Supervisor OK
c0000005 when trying to send a report to the BCA
Unhandled exception error in BO 6.1.0 when refreshing report
C000005 AGAIN
unhandled exception on videocard
BCA and memory usage
BO ZABO 5.1.4 DB2 & timestamps produce c0000005 error
How can I change the universe name from a data provider?
Unhandled Exception Error C0000005
BO 5i on Win 98
FAQ: Reporter
VBA Editor will not open
System error when drill down with a global filter
Wish list for new release of BusObjects & Webi
Error when "If Object = Variable"
FC 5.1.5 Aborts when Query Panel Icon is pressed
Automation Exception
Report crashes while trying to refresh in 5.15, fine in 5.10
unhandled exception
Connection errors
Report not being refreshed at the 3'rd time
EXCEPTION_ACCESS_VIOLATION C0000005 - unable to open report
Adding Condition After exporting
Unhandled exception
Refresh a Report
Can not open List of Derived Tables for BO6.5 SP3.
Un handled Exception during refresh
Unhandled Exception Error C000005 - with a twist
Is there a restriction On the number of Variables ?
Unhandled Exception Error C000005 - with a twist
Unhandled Exception Code: c0000005
Unhandled Exception during object parse
Error starting DI: c0000005 EXCEPTION_ACCESS_VIOLATION
Unhandled exception
Cannot Import Universe - Exception Access Violation
Save as Text - Unhandled Exception Error
Unhandled Exception
reporter error

Nice listing of possible causes…
I would like to put it the other way round though, from a support perspective;
when a user reports the Unhandled Exception, my heuristic is to first ask whether the error happens when refreshing reports from a particular universe only, in case of which cause and resolution 3. applies. Next I would go for the corrupted …CURRENT_USER registry (1.) by asking the user whether a co-worker, logging-into BO with a different BO account (on the same machine), experiences the same error. If the user-account doesn’t matter either, then I would go for the other causes (wrong dll, old machine, huge report).



Wolfgang (BOB member since 2002-08-19)


One of my users is facing this unhandled exception error. I tried all the resoutions and have come to a conclusion that $4 mentioned by you must be causing it. One solution that I could think of is, have his machine totally redone. Is there any other way? Could you elaborate upon what you mean by ‘trying to track down the corrupt dll’? How can that be done?

-Rahul Ghate

Rahul Ghate (BOB member since 2002-08-23)

Rahul, what I would do is look at the text of the error where it mentions a number of dlls. What is the first dll? Find it on the PC, what version is it, what is its date and time? Compare this information to that of the same dll on a machine that works? Any differences? What about the next dll…and so on. Not very scientific but it has worked for me in the past.

When does the error occur exactly, as resolution 4 is quite a rare one…?

cheers, Nick

Nick Daniels :uk: (BOB member since 2002-08-15)


The error occurs when the user tries to open any document on his machine or from the repository. He can create new documents and open them subsequently, but any other document gives this error even if it is as small as a 100 kb. I did a de-install, cleaned up the registry, re-installed 5.1.5 but to no avail.

It gives a list of whole bunch of dlls (may not necessarily be the same every time the error occurs, but they are around 10-12 in all), and tracking each one of them down will be a pain. Is there a quick fix like just copying those dll’s from another machine onto this machine and registering them?


Rahul Ghate (BOB member since 2002-08-23)

Sure, go for it. Make sure you back up the current dll’s first though.

Nick Daniels :uk: (BOB member since 2002-08-15)

Here’s our fix procedure (HIH):

Possible Solutions to this problem:

  1. Delete the offending universe from the universe\universe folder
  2. add the correct mfc42.dll file (4.21.7303) to the Program Files\Business Objects\Business Objects 5.0 folder
  3. Rewrite the query
  4. Backup the mfc42.dll file in the winnt\system folder and replace it with the correct one (4.21.7303) (Note: this could potentially have adverse affects on other products (particullarly norton))
  5. For Designers that can’t get in (i.e., Win2000 users) … Uninstall the product, Purge the Registry for all Business Objects Entries, Reinstall

Chris Pohl :us: (BOB member since 2002-06-18)

My twist - this problem yesterday was for one report only. The Designer/Reporter was 5.1.2. He published to SP 4 in Webi. ZABO user in 5.1.3 was getting connection error DA0004 and the report never ran. She uninstalled 5.1.3 and downloaded 5.1.4. Problem went away. YES :!:

Meanwhile the designer modified this report and published as test version. He and I can run the report in full client. Us or anyone in ZABO gets the Unhandled Exception or a connection error DA0004 or even sometimes it hurts so bad that BO just quits, FLASH :shock: with no message. I upgraded the designer to 5.1.4 but by now the report was so corrupted that I sadly suggested he start over on a previous working version. AND - I had upgraded to SP6 during all this and the corrupted report was OK on my PC thru ZABO but SP 6 has that other problem I posted this morning.

Somewhere in here is the key to all the errors :confused:
But I think the report got corrupted for any number of reason: difference in version, complex filters (KX res 10849) and lots of variables and reports tabs and overall large size.

scott copeland (BOB member since 2002-08-15)

Hello All,

Another (apparent) cause/solution that I have found to the Evil Unhandled Exception Error is corrupted universe objects, as opposed to the entire universe being corrupted. And another symptom of them I have encountered is that the universe imports, but the object formatting or results don’t display in Reporter as they are set in Designer. (Du du du du, du du du du: “You have now entered…the Twilight Zone”.)

I have encountered this problem a couple of times, and both times the only changes I had been making to the up-til-then functioning universe was editing or creating just a few universe objects. As I analyzed what I had been doing just before the problem occurred, the only thing that stood out was that I had been making rapid and/or multiple changes to objects; for example, both changing an object’s format style and at the same time deleting an existing style from the list displayed. :crazy_face: A memory pointer problem, perhaps??

When I deleted these recently-edited objects, saved the universe, and then recreated the objects from scratch, VOILA!, no more problem. :smiley:

So now I make it a habit to make object changes more slowly and save them often, hoping this will help pre-empt the problem.

JP Brooks
Kemet Electronics Corp.

P.S. Cutting and pasting the SQL from old to new objects gave no problems, but copying an already corrupted object as a new, renamed object resulted in an already-corrupted new object.

JP Brooks :us: (BOB member since 2002-10-22)

Hi there,
Thanks for all your comments about the annoying UNHANDLED EXCEPTION ERROR. We also have experienced this situation in both Business Objects 5.1.2 and 5.1.3, and in most cases deleting the universes from c:\ or letting the client machine using more swap memory fixed the problem.
But now things are getting worser, since we faced an upgrade to SP6 (Business Objects 5.1.6, Web Intelligence 2.7.2). When our users try to edit the existing reports (made with the 5.1.2 and 5.1.3 versions) using ZABO clients through a new BO SP6 server they always get the UNHANDLED EXCEPTION ERROR in cube50.dll. :frowning: If we try to edit / refresh documents with the full client in both SP3 and SP6 versions everything works fine, so I asume the problem may be related to the Zabo SP6 server.
We opened a case with Official Business Objects Support and the only answer that we got is that there may be some kind of incompatibility between SP3 and SP6, and suggested to open and save the reports with other name :shock: (didn’t work) or get them all redone in the newer version :reallymad: (really madness, since we have lots of legacy reports).
Is anyone experiencing the same problem? Any advice would be really appreciated, i’m afraid we will have to abort the upgrade and stay in BO SP3.

Our Server: Windows 2000 Server SP2
Our DataBase: Oracle 8.1.7 (repository and data)
Our Clients: Windows 2000 Professional SP2


AGRodeja (BOB member since 2002-09-03)

We are at 5.1.4 and I stopped installing 5.1.6 for the reasons I stated below. There was also the issue of the change in the way corporate documents are read (between 5.1.4 and 5.1.5) and I felt if I was going to have to make that concerted and long effort to get EVERYONE moved to the new version, it would be better to wait until sometime in version 6.

scott copeland (BOB member since 2002-08-15)

Look HERE for another recovery procedure from mark_it (UH.EX. using Designer)

Chris Pohl :us: (BOB member since 2002-06-18)

You’re going to love this one. 8)

We had a 5.1.6 report with 6 queries and a VBA macro. If we tried to run the macro it gave the UEE straight away. If we tried to refresh the report it gave the UEE straight away. If we tried to run a single query, the query would run for a few minutes, and indicate it was bringing back data…tehn give the UEE straight away.

I should mention that the report had been written by someone else, then copied to a network drive, from where we picked it up. We tried a number of things, but when we got the user to send the report to a supervisor in the repository and then retrieved the report - hey presto it was fixed. I’ve been assured that it was the exact same report.

So there is something to make your eyes bulge… :shock:

Nick Daniels :uk: (BOB member since 2002-08-15)

I was reading in some of the posts that machine configuration could be a contributor to the “UEE” rearing its ugly head when attempting to open/run larger reports. I have a “latest and greatest” machine (i.e., 1.7 CPU and 523 mem), but have noticed some of our users have older machines and have encountered the UEE beast intermittently when attempting to open reports in ZABO. Is there a recommended minimum configuration for WebI/ZABO/FC users?


John Phillips :us: (BOB member since 2002-10-01)

Another thing to check for when getting UEE is the connection type - make sure that it is set to disconnect after every transaction. I understand that this “feature” is particularly prevalent when working with an Oracle database.


What is this information based on Mark?

Nick Daniels :uk: (BOB member since 2002-08-15)

Nick, it’s the advice offered by a UK Business Objects reseller.

Worked for me.


We have the Connection Properties set to “Disconnect after each transaction.” We switched to this setting based on the advice of a BO technical rep. after having problems with our connection being repeatedly dropped when using the “Keep the connection active during the whole session” (which resulted in us having to restart Designer and/or BO to reestablish a connection).

John Phillips :us: (BOB member since 2002-10-01)

We had a problem where one set of users could open BusinessObjects reports fine, and another set could not (BO always crashed when they opened reports - the old c0000005 Unhandled Exception error :evil: ).

Eventually we found that all users needed to have a default printer defined :shock: . (Those that didn’t have a default printer received the unhandled exception!)

The Event Log showed a Warning that some HP drivers had been installed. Presumably BO or XP was trying to setup a printer in order to render the reports.

Anyone else come across this?

Windows XP / BO 5.1.4 and 5.1.7


andreww100 (BOB member since 2003-06-27)

Will the variations never end?

Today, I got a ‘c000001d’ EXCEPTION_ILLEGAL_INSTRUCTION message. This occured on 5.1.6 with a slow running report whilst trying to open Designer. Reporter crashed out with multiple Blue Bug screens, but I could re-start from where I was thrown out and nothing seemed to be broken.

Nick Daniels :uk: (BOB member since 2002-08-15)