BusinessObjects Board

Http 404 Page cannot be found error

Here we go again!
always the same problem!

I cannot run Full Client reports in Webi 6.5.1 they result in a http 404 page cannot be found error. It’s installed on win2003 server :lol:

The full client (also installed on this server) is running with no problems.

  • bomain.key is correctly named
  • parrent path is set in IIS (6)
  • ASP’s are set to allowed
  • environment variables are set.
  • User which runs webi is part of the OS and can log on as a service.
  • in DCOMCNFG user which runs webi has got full controll in DCOM Configuration permisions(launch permissions and access permissions are set to default)

I can’t see a BO manager process, but I don’t know if this process should be visible all the time?

I can see all corporate documents and categories but reports don’t show (it does show the refresh icon fo a second:“waite while your report is retieved” but then it bounces to the http: 404 page cannot be found)

anyone any clues?
No it’s not possible to go back to win2k :nonod:

Tiny :netherlands: (BOB member since 2004-11-10)

Does this happen to all view options HTML, PDF and Enhanced ??

I came across a similar problem as the ActiveX control could be downloaded as users did not have rights to do so. In that case Browser showed similar behaviour, but they were able to view it in HTML and PDF


mada :denmark: (BOB member since 2004-11-25)


what permissions do you have set in IIS for wiasp and the default directories? Also for the webi cluster services have you got it set to Log on as local system account and ticked allow service to interact with desktop?

irish_stan :ireland: (BOB member since 2003-05-13)

Yes, when I change viewing options to PDF or enhanced it still shows the same message

Tiny :netherlands: (BOB member since 2004-11-10)

WIASP properties in IIS are set as follow(virt dir):
-Read (checked)
-Log visit (checked)
-Index this resource (checked)

The webi cluster services is set as follow
Log On: This account: “local” admin account (local system account is NOT checked)

I don’t no what you mean “ticked allow service to interact with service”??

Tiny :netherlands: (BOB member since 2004-11-10)

Just to confirm our settings. we require our users to use windows authentication. We are on W2K3 IIS6 BO6.5.1 ASP Config.

  1. webi Cluster properties set to Logon as local system account and allow service to interact with desktop ticked.

  2. IIS6

a) wiasp properties Execute Permissions - scripts and Executables, directory Security IWA Set- Anonymous unticked.

b) Same for all sub directories except bin and classes which have anonymous ticked (otherwise we got a problem with the java applet downloading)

c) Plus the other IIS6 stuff you have already done parent patch asp extensions etc.

irish_stan :ireland: (BOB member since 2003-05-13)


Think you will find the problem is with the WebiCluster. settings You want to change your settings to the Local system Account - Radio button and then tick “Allow service to interact with desktop”

irish_stan :ireland: (BOB member since 2003-05-13)

I have done the above (set WebiCluster to Local System account )
and I also set WIASP Execute permissions to Executable and Scripts (and allowed it to do it for all directory’s beneath it)

I rebooted the machine (just in case) but still the same

Tiny :netherlands: (BOB member since 2004-11-10)

stan I can’t find the IWA Set - Anonymous unticked part which you are talking about… (in which part of the Directory security Tab is it?)

Tiny :netherlands: (BOB member since 2004-11-10)


Did you also modify the Directory Security Settings for Anonymous access and authentication control?

irish_stan :ireland: (BOB member since 2003-05-13)

No I did not change those settings (Authentication and Acces control)

On WIASP level they are NOW set to:

  • Enabale anonymous access IS CHECKED
    a user is filled in: IUSR_nlrat-wias001 (not the user which is starting webi)
    and a password is filled in

all the other boxes in this screen are NOT checked.

Tiny :netherlands: (BOB member since 2004-11-10)

wiasp - properties - directory security- anonymous access and authentication control - edit.

As I said we are using windows authentication so we are using IWA here. I am not sure If this would stop you viewing your FC documents

irish_stan :ireland: (BOB member since 2003-05-13)

After I hit edit in Authentication and access control I get the following screen: (see attached word doc)

Where do I need to adjust something>?
Authenti and access control.doc (32.0 KB)

Tiny :netherlands: (BOB member since 2004-11-10)

Sorry for the delay I have been in a meeting. I unticked the anonymous authentication and then ticked IWA.

By the way when you were in the Webi Cluster service did you tick the “Interact with desktop” option?

irish_stan :ireland: (BOB member since 2003-05-13)

I unticked Anonomous login and ticked IWA but with the result that I wasn’t able to log in (so no good option for me)

And yes I also ticked “Allow service to interact with desktop” with the webi cluster service.

Should BO manager proces (in task manager) always be present???

Tiny :netherlands: (BOB member since 2004-11-10)

it works!
I think it was the combination of your settings Stan and a reboot of the machine!!

many many thanks

for further reference, my settings:

  • local system account for Webi cluster service and tick the interactive with desktop checkbox
  • also make sure #17405 form Knowledge base is applied
  • and in addition I also allowed the ISAPI extensions (watch out!)
  • WIASP virtual dir. should allow scripts and executables (watch out for Irish -Stan’s remarks above that some sub-dir’s should not be granted because else java applet gives troubles)

Tiny :netherlands: (BOB member since 2004-11-10)

Hi Tiny,

glad it worked for you in the end. Just one thing to be wary of (I suppose it is obvious) If yoy have to reconfigure for any reason it will change all the settings in the cluster manager.

irish_stan :ireland: (BOB member since 2003-05-13)


Can you tell me what these are - "c) Plus the other IIS6 stuff you have already done parent patch asp extensions etc. "

I am having this HTTP 404 error as well. I have checked all of the other settings in this post, but am not sure if I have the parent path, asp extension and the etc right.


maprice :us: (BOB member since 2002-10-23)

Hello Tiny,

Did you manage to resolve your Pb ?

I have actually encounteres the same one with a similar configuration as yours.

fguionne :fr: (BOB member since 2002-08-16)

Sorry, I didn’t see there was a second page…

So my question remains : did you manage to solve your problem while keeping your IIS set as ‘Anonymous’ access ?

I have the problem with the anonymous access set and not via NT authentication

fguionne :fr: (BOB member since 2002-08-16)