BusinessObjects Board

FRM0008 - You are not authorized to use this document

I have a user that is getting FRM0008 - not authorized to use this document. He created the document. I had read some posts that state if it was deleted from repository that could be the problem. I just checked and it’s scheduled on the broadcast agent. So that’s not the problem. This is the 2nd report of his he has called me about any ideas why this is happening.

I am just signing in as gen sup and saving for all users. But trying to figure out why he is getting this all of a sudden.


Stacy Woodring (BOB member since 2002-08-15)

Stacy, I beleive the document can be deleted and still be scheduled. I had a similiar issue 6 months ago, my user had rights to publish doc’s, she would delete, and see this message next time she tried to access her doc locally. “Save for all” as you are doing or a SRC would resolve. However, after I explained the problem to her I have not seen this message. Have you asked user if he/she is publishing (then deleting) the documents in question.

jswoboda :us: (BOB member since 2002-06-20)

I just asked him. Sometimes he has been deleting and rescheduling. I told him to reschedule first. Then delete the old schedule. That should work right?

Sometimes he deletes then reschedules which way is safest.


Stacy Woodring (BOB member since 2002-08-15)

Stacy, I was actually refering to deleting documents from corporate documents (publish to), but you are saying the user is deleting the document from the BCA console - right? I don’t think that should be a problem. Hold on, I’m thinking… (if anyone else knows the answer feel free to chime in)

jswoboda :us: (BOB member since 2002-06-20)

I agree with Jeff. I don’t think scheduling has anything to do with this. Is this a corporate doc? Is it still in the Corporate Doc section?

Steve Krandel :us: (BOB member since 2002-06-25)

No it’s not a corporate document and never has been as far as I’m aware.


Stacy Woodring (BOB member since 2002-08-15)

I saw that this post is open for a long time without any final comments.
Did it actually resolve and if so then how?

Please advise - we have a single user who has the ZABO for 6.1b on her PC and is not able to open any reports locally.

Help is appreciated (I know, that’s what everybody claims) - I would really like to offer a solution to the user :slight_smile:

Thank you very much!


benderr2001 :us: (BOB member since 2004-04-05)

You might find some useful information in this FAQ entry.

Additionally, this is how I understand document authorization. This discussion assumes the use of a repository:[list]- A “brand new” document is owned by the user that creates it. No one else can use it.

  • Once a document is exported to the repository, it is subject to authorization as defined in the repository, it is no longer tied to a user.
  • Any document (whether exported or not) can be “unsecured” by doing a Save As and checking the “Save for all users” box.[/list]

Dwayne Hoffpauir :us: (BOB member since 2002-09-19)

I am just signing in as gen sup and saving for all users. But trying to
figure out why he is getting this all of a sudden.

You don’t need to save for all users!!

Every user can create a dummy repository on his own, and be General Supervisor of that repository.

For example, you can create a repository basing on a Access MDB document.

In that dummy repository you are General Supervisor (hypothesis: you have a client BusinessObjects with Reporter, Designer and Supervisor installed), so every user can open the “.rep”, save for all user, log out from the dummy repository and relogin in the REAL system.

Donald Duck :mexico: (BOB member since 2004-07-29)

Gee – you have that many Supervisor licenses? :shock: We sure don’t – we have just two.

Our users are all only licensed for WebI and ZABO Reporter. They can not create a repository with only those licenses.

Anita Craig :us: (BOB member since 2002-06-17)

For the longest time I could not open some old reports that I wanted to use as examples because I forgot to set the ‘Save for all users’ option. :wah:
So the other day I went to Bob and searched on the FRM0008 error message and found this post. :blue:
When I got home, I did exactly what this post said to do, and WOW it worked. :rotf:
Now I can OPEN and use my old report formats and VBA code. :crazy_face:
Thanks Bob :mrsbob: for your search function and thank you Donald Duck for this answer.

Barry D. Beaton :us: (BOB member since 2002-07-19)

Hi –

I have similar issue.
Env : BOXI3 -sp3 on windows 2003 with Tomcat.

User (user1) has the two accounts Windows AD and Enterprise.

If User logged from his PC either with WindAD or Enterprise to import the document from Deski, he is getting the "You are not authorized to use this document FRM008).

If he logged from other machine through Deski, there is no error message.

What could be the issue ?. :hb:

Can someone please share the resolution.


forumpt (BOB member since 2008-10-02)

There is a workaround to restore access to these reports as written below.

  1. Create a new document from the same universe as the report which is locked, it can be a simple document. Export it to the CMS and write down where you exported it to.
  2. Go to the CMC in the “Objects” section and find this new document in your list of objects. Go to the Document properties and see the physical name and path of the binary object into your file store, for example : frs://Input/a_132/001/000/420/azpv1zmgkojaqwertyajr.c.rep
  3. If you know the path to your FileStore Input folder, then go to that path, if you don’t know where is your Input folder you can look in the CMC, into “Servers” section, click on the module named “Input.”, in the properties of this Input module you will see the full UNC path of your File store.
  4. Once in the subfolder Input/a_132/001/000/420/ backup the report file. Note: the file name is the same as the CUID of the report object.
  5. Rename the locked report file to the same as the report in the filestore, in this example “azpv1zmgkojaqwertyajr.c.rep” and copy/overwrite it to the filestore.
  6. Open Deski and retrieve the report from the CMS which you have created during step 1. It will show you the blocked report!

To prevent this from happening in the future you can do the following:
Save your file system reports “for all users”, this however can be a security risk! Note, mind the following sequence otherwise you will have the same issue!
.create report
.export to cms
.save the report for all users (and overwrite when asked).
1Make sure you backup the reports which you exported to the cms with the use of e.g. a version control system like LCM or by simpely copying the reports to a “archive” folder.

sajildas (BOB member since 2012-09-26)