"Your universe contains broken links" - can't fix it

I googled this and I see the broken link, but I can’t remove the broken link.

I have a local project and renamed data foundation and business layer.

I changed the Data Foundation … I click on “Show Local Dependencies” and see the broken link (and the link to the newly named dfx …) then then what?

I’ve renamed the local project, restarted IDT …

In Show Repository Dependencies, it shows the re-named blx is dependent on the original name. But you can’t change anything here.

What’s a fella to do?

Did you repoint the business layer to use your new/renamed data foundation?

Open the BL, click the top level in the object tree to select the BL, then click the Change Data Foundation button over on the top panel on the right and select your new DF.

1 Like

Yes, I did that, still it’s saying “broken links”.

I also had changed the name of the local project - no dice. Then I created a new local project and copied everything in, but the broken links were also copied in …

So I changed the name of the data foundation layer back to it’s original name, and now we’re good …

Is there an easier way to change it in CMC?

It’s not possible to make that change from the CMC. The CMC just lists the unx, not the components of the unx.
The only way that I know of is through the IDT the way that @dtolley described, but I haven’t worked with IDT much yet.

Did you rename both the DF file (click on the DF in projects and select rename) and change the name inside the DF itself (top level in tree - properties/name in the top right panel)? Save. Then repoint the BL?

1 Like

ah, that might be it … I will try tomorrow … thx!

that worked! Thank you … :grinning:

1 Like