Webi Send To Button Disabled

Hello,
I’ve weird situation when opening webi report in BI launch pad.
I’m not able to send the report to user’s inbox or in email after report is open webi. The “Send to” button is disabled. However, there is no issue if I select the report from the folder then right click and I can select “Send to” inbox.
I’ve given Full Control access to the group “Everyone” and I still don’t see “Send to” button activated when a report is opened. The user “T_send_to” is a member of “Everyone” group. I’ve given the “Everyone” group to Full Control access to “Monitoring Report Samples” folder. Here are other access Everyone group has (CMC):

  1. Inbox – Full Control (not the Full Control (Owner), but Full Control)
  2. Personal Folders – Full control
  3. Temporary Storage – Full Control
  4. Application–> Web Intelligence – Full Control
  5. Application–> BI launchpad – Full Control
  6. Folder – Full Control

I even tried adding this user “T_send_to” to "Administrator group and “Send to” is still disabled. See SS attached.
What other access controls the “Send to” access in webi? :hb:

I’m currently using BO 4.2 SP2 in tomcat/Java env.

Any help would be appreciated.

Thanks,
Webi Send to disabled.jpg


zulu1900 (BOB member since 2005-07-27)

Hi
I don’t have CMC access at my current site, but that is an Application Right for Web Intelligence application
I found a screenshot of where you need to apply the rights. I hope that is enough information to point you in right direction
webiSendTo.JPG


buzz :australia: (BOB member since 2005-08-12)

Thanks for your suggestion, but the “Everyone” group is currently assigned with “Full Control” access fro Web Intelligence application. And Full Control access has those rights “Granted” by default.
Here are the rights that’s currently set for “Everyone” group in CMC:

  1. Inbox – Full Control (not the Full Control (Owner), but Full Control)
  2. Personal Folders – Full control
  3. Temporary Storage – Full Control
  4. Application–> Web Intelligence – Full Control
  5. Application–> BI launchpad – Full Control
  6. Folder – Full Control

What else I can try?

Thanks for your help!


zulu1900 (BOB member since 2005-07-27)

Phew…
after I long try I figured out the cause of the issue. There seems to be a lot of reasons why “Send to” button is disabled in WebI; from Inbox folder to Temporary storage to personal folder to application.
In my case, it was Application–>Web Intelligence. The Full Control access did not have “Add Objects to the folder” right granted. It’s under Override General section. Go to Application–>Web Intelligence–>User Security–>Included right–>Advanced Right–> find Application collection then Web Intelligence and find “Add Objects to the folder” under Override General.
Once we granted this right I was able to see the “Send to” button activated.
I’m now checking on how to disable (or remove) “Send to Mail” and “Send to Ftp” option from the menu. I don’t want to give those option to my users. We don’t have these configured.

thanks


zulu1900 (BOB member since 2005-07-27)

Look under the Customization settings. I’m not sure if it’s that granular, but it would be a good place to start.


joepeters :us: (BOB member since 2002-08-29)

Yes, I was able to disable those by removing “Send to” rights (Explicitly Deny right) from Application --> BI launch pad.
Open custom access then go to add/remove rights then Application --> BI launch pad and check Deny rights for the following:

  1. Send to email destination
  2. Send to file location
  3. Send to Ftp location
  4. Send to SFTP location
    Apply or click ok to complete the selection.

Now, everything works perfect.

As always thanks for your help and suggestion.


zulu1900 (BOB member since 2005-07-27)