BusinessObjects Board

WebI Report Based on CSV - Schedules getting failed

We are on BO 4.1 SP05. We have created a webi report based on CSV. The csv is kept in the BO server filestore/input path.

The report schedule is getting failed with the error message “You do not have the right to access data returned by this universe.”

We are using administrator account which is having full control on the folder and the report.

Can please someone let me know why the report is getting failed? Where else we need to provide access?


developerbo13 (BOB member since 2016-09-12)

You way need to check the security on the universe connection or file path.

richardcottave (BOB member since 2006-03-30)

Could you please elaborate a bit.

I have placed the csv file in my remote desktop C drive in CSV folder and tried it but still I am getting the same error.

I have enabled the share property of the CSV folder. What else do I need to check while checking the security of the file path?

As I am taking the data from csv for the first time, I do not have any idea about it. Kindly help.


developerbo13 (BOB member since 2016-09-12)

I have seen that error message associated with security on universe connections but if you are not using universe I’m not sure where to look. Sorry.

richardcottave (BOB member since 2006-03-30)

Can someone give me some idea please?


developerbo13 (BOB member since 2016-09-12)

Put the csv in to the Launchpad, by adding it as a local document and build your query off it from there.

Nick Daniels :uk: (BOB member since 2002-08-15)

I tried this as well but I am getting same error “You do not have the right to access data returned by this universe”.

My requirement is to create a report based on csv stored in a shared location. Everyday new csv will replace the old csv and the report will show the updated data.


developerbo13 (BOB member since 2016-09-12)

I am able to resolve the issue. In the Webi rich client, I unchecked “Refreshable” and now I am able to schedule the report.

Now the issue is when the new csv file is replacing the old one, the webi report is showing the old data not new data.

Any idea why it is showing old data and how it can be resolved?


developerbo13 (BOB member since 2016-09-12)

HI, I appreciate this is a really old post, but did anyone have an answer to this problem?
To clarify any thing that might be missing …
My infrastructure team have recently removed a “user” group from a network folder that stored a number of CSV’s .
All the scheduled jobs that use the flat file data connection type are now failing with the message.
“You do not have the right to access data returned by this universe.”
My gut is telling me I need to some how give my BO Server or the Built-in Administrator Account a Windows credential to use when accessing resources on the network.
But i am not sure where to do this? SIA ?

If infra have removed it, then it will be Windows permissions to access that network folder.

I switched to using a domain-level service account for scheduled reports against files - I’d suspect that you need to do the same.

Thanks Mark.
That’s looking like the fix.
I have tested changing the account that the SIA uses from “local service” to an AD account that:

  1. Is in the Administrators Group on the BOBJ Server
  2. Has access to the network location that the flat file is stored in.

Lookin good so far,

1 Like

Thanks for the update. Hope it works out for you.