WebI Design option is grayed out

After moving the users from BO4.1 to BO4.2. User are able to right click their reports in their My Favorites but the Design option is grayed out.

In BO 4.1 the option is enabled. But in 4.2 it is disabled.

I have confirmed the Access Level in General and under Web Intelligence application and they have access modify their objects owned by them.

Not sure which option could be causing this issue.

Please advise,
Thank you.

kpiracha (BOB member since 2011-03-23)

Check their access to the universe & connection as well.

joepeters :us: (BOB member since 2002-08-29)

Both are there. They can run the report fine. This means the universe and connection access is there. The odd thing is that in BO 4.1 sp4, the button is available. In BO 4.2 sp7 after migrating them from 4.1 sp4, the button is grayed out.

Still waiting for some advise.

kpiracha (BOB member since 2011-03-23)

Is there anything in BO 4.2 regarding permission not in 4.1. The permission in both system is the same but users still can’t modify their own report in 4.2 but can do it fine in 4.1.

kpiracha (BOB member since 2011-03-23)

What editor were you using? Java or HTML5?

FrustratedScot :uk: (BOB member since 2006-04-27)

I tried both HTML and Java.

I also tried one more thing yesterday. I assigned the ‘Full Control’ access to the Group users were part of but the problem still existed. Not sure what could be causing this.

kpiracha (BOB member since 2011-03-23)

Are they able to create new reports using the same universe?

If you explicitly give them Full Control to the report, does it help?

joepeters :us: (BOB member since 2002-08-29)

Issue is fixed by giving ‘Groups’ access to the Web Intelligence application.

kpiracha (BOB member since 2011-03-23)