BusinessObjects Board

Scheduling Error in BI4.2


We’ve recently had a new instance of BI4.2 SP3 Patch 2 installed but when any of our high level users try to schedule a report they get the following error…

The error appears when the ‘Schedule’ button is clicked.

I’ve checked the access rights and I can’t see any reason as to why the scheduling won’t work. However, it works fine for anyone in the Administrator group!
We also get this error when a user tries to change their Preferences, but again, it’s fine for Administrators!


C4RL_BI (BOB member since 2017-02-01)

We’ve recently update to BIP 4.1 SP8 to BIP 4.2 SP3 Patch and can confirm Schedule works fine for Non-Administrators.

Maybe verify access levels as sometimes to you end up reviewing/modifying them based on your organizations security requirement.

I know of a instance where BIP 4.1 default VIEW Access Level provides all users the ability to “Application --> Analysis edition for OLAP --> Create Analysis Workspace” which violates your SAP License agreement especially if you’re on Concurrent Session License.

Lesson learned: ALWAYS check, re-check default access level.

Hope you find the problem in your environment soon…

viru4808 :australia: (BOB member since 2008-01-09)

Did anyone ever get a fix for this? Facing the same issue, strangely it only occurs if the you click on the ‘Format’ option in the scheduler, I can schedule as long as I don’t touch that which led me to think it was access levels on content??

We upgraded from 4.0 SP2 to 4.2 SP3, everything worked fine pre-upgrade.

any thoughts appreciated.

juno (BOB member since 2008-06-23)

Hi BOBJ experts,

I can confirm that 4.2 SP 4 gives me the exact same error as juno mentioned for SP3… still not fixed.

Anyone have a permanent fix for this yet?

As a workaround I found that this works:

  1. Add user to administrator group
  2. Login with user, schedule a Webi Report and select Formats tab (Where the error popped up in the past)
  3. Remove user from administrator group
  4. Login with user, schedule a Webi Report and select Formats tab
  5. Now the user can schedule report to all formats without being in the Administrator group

Thank you

GerrieGreyling :south_africa: (BOB member since 2013-04-08)

I’m getting a similar issue after filling in data for the Prompts section.

If view the report and click refresh, the same Prompts come up and after inputting the data the report works fine.

This issue only happens when scheduling the report.

Running 4.2 SP3 Patch 8

JustinCowbell (BOB member since 2017-10-11)