Refresh on Open checked - but report doesn't refresh on open

Hi All,

BI4.1 SP07. A Webi report created in the Java Applet has the “Refresh on open” document property checked but it doesn’t. When you open the report it opens as empty and you can then manually refresh it and it works. If you save it populated the data isn’t consistently saved in the report.

The report uses an IDT UNX Universe and has two queries on the same universe. One query uses a universe defined prompt and the other uses this and also has a report defined prompt for another field.

Any ideas? I’ve tried saving off somewhere else, loading into Rich Client and saving off, saving with the option enabled/disabled then re-enabling etc. I’ve also tried enabling from the Save As … dialog. Nothing seems to work.


DanDensley :uk: (BOB member since 2009-05-12)

The report was successfully recreated from scratch. Root cause thought to be related to the report having been originally created on a different system and then migrated. Possibly fixed in SP08+. Potentially related SAP notes:

http://service.sap.com/sap/support/notes/2266942
http://service.sap.com/sap/support/notes/2229633


DanDensley :uk: (BOB member since 2009-05-12)

Thanks for sharing the update. That does appear to be the cause of your issue.


joepeters :us: (BOB member since 2002-08-29)