Please help - I cannot change data source

Our software providers used promotion management to upload a report (LCMBIAR file).

However, although our self and the software provider are using the same universe. They have named theirs differently. Which means within the report there are 2 sql queries that are looking for a universe name that doesnt exist on our server.

They said to change the data source to point these sql queries to our universe. But the option to do this is greyed out.

Greyed out

So then I went into the Query panel to try and change it from there but i get this

Which report editor are you using? Have tried the Applet, the HTML, and WebI Rich Client all three?
Is this in the FIORI BI Launch Pad or the legacy BI Launch Pad?

What version of Business Objects are you using? The SAP Site KBA 2850234 says there was a bug with BI 4.2sp4 patch 7 for reports that were promoted using Promotion Management. It’s a little circular to get to the resolution but it looks like this particular issue was fixed in BI 4.2sp8.

BI 4.3 isn’t mentioned.

Hi,
my users usually get this when have wrong permissions. As the permissions can be set quite granularly that e.g. allow editing the form/report but disallow changing the data provider. Similar behavior - no real error just the same message.

1 Like

@JohnBClark Yes i have tried all three with the same outcome. We are on version 4.2 Support Pack 7. Which I’m assuming is the problem. However, I dont have access to the SAP support portal because BO came with our HR, Payroll and Recruitment software. So they did not give us a login for SAP, instead all our support for BO has to go through them.

The problem is, they have remoted in multiple times and can not fix this issue.

@tom_kar Thanks for your reply. I am a system admin and have full access on all universe and connections.

I have even tried logging into Business objects with our master cmc admin account and get the same error.

I have even tried it when i have manually ticked all permissions on my user.

Thank you both again for your replies. Im ripping my hair out with this lol

Im thinking how should I simulate this…
by renaming an universe it will not break the relation report - universe… I think I must delete a universe and then reimport it as new one with another ID…

I did this once in XI 3.1 and had to fix it via SDK…

I have tried to reproduce this, but could not make it.
The only hint I have, it seems the message The query cannot be edited is displayed for security right Desktop interface - Enable local data providers, this can be defined in Applications - Web Intelligence.
Strange is also, that there is no data source displayed on the menu item.
Did you check the change source for another document ?