Oracle Connection Problem

Hi,

We are migrating our universes from Oracle 10g and boxi 3.1 to 11g express with BO BI 4.2

I already moved the tnsnames.ora file, and the connection tests successfully, but when I retrieve tables, I get a “unexpected behavior” message.

Did I forget to update something eles (e.g. sql.ora, environment variable, etc.) or is this possibly a connection issue?


indy (BOB member since 2004-04-08)

Perhaps this is a 32 bit vs 64 bit issue?

4.2 is 64 bit
Designer is 32 bit

What version of oracle client did you install?

Install 32 bit Oracle client on your workstation alongside designer and see if you get the same issue?


jemstar :ireland: (BOB member since 2006-03-30)

32-bit


indy (BOB member since 2004-04-08)

Are you using a compatible version of the Oracle client middleware?


joepeters :us: (BOB member since 2002-08-29)

I do not know. How do I find out?


indy (BOB member since 2004-04-08)

You’ll need to look at the Product Availability Matrix (PAM) for information about which version of database client will work with your version of BOBJ.

Also, all of the client tools are 32-bit so you’ll need to have the 32-bit Oracle client installed on the machine(s) where you’re using the UDT or IDT. However, with the exception of the Crystal2016 servers, everything else in the BI platform is 64-bit so you’ll need to have the 64-bit version of the client installed on the servers where BOBJ is installed.

Unlike 3.1 and earlier, best practice is to NOT install any of the client tools on the servers where the BI Platform is running. One reason for this is so that you don’t have to install both “bit-nesses” of DB clients.

-Dell


hilfy :us: (BOB member since 2007-04-16)

So if I am understanding correctly, install only the 64-bit 11g Oracle express edition on the server and uninstall all the client tools.

On the client machine, install 32-bit 11g Oracle express with the client tools installed.

The tnsnames.ora file needed to be the same on both the client and server. Correct?


indy (BOB member since 2004-04-08)

That’s correct.

I would install Oracle before the client tools, but it should work with either one installed first.

-Dell


hilfy :us: (BOB member since 2007-04-16)

After performing the following, a new error message:

The server is not responding SBO0001

Do we need to install both the 64 bit and 32 bit Oracle clients on the server? Should we also do this on the client machine? Does it matter if Oracle is installed on the C: drive or D: drive?


indy (BOB member since 2004-04-08)

What are you doing when you get the error message?


hilfy :us: (BOB member since 2007-04-16)

We created the connection using the UDT, and the test was successful. After creating the connection, when we attempt to apply it to a new universe or an existing one, it produces the message:

The server is not responding! (SBO00001)

CS: Unexpected behavior

I actually tried to install both the 32-bit and 64-bit on the server. However, this was not possible as it noted that a current installation exists.

Desperate at this point, I was able to even successfully create an ODBC connection with Oracle. But again, when I use designer, it generates the same error message as stated above. :hb:

Any thoughts?


indy (BOB member since 2004-04-08)

Any other thoughts guys? I still haven’t figured out a work-around


indy (BOB member since 2004-04-08)

Did you uninstall and then re-install Oracle without uninstalling BO? That might have done it. I would suggest:

  1. Uninstall all Oracle clients
  2. Uninstall BO
  3. Install 32-bit Oracle
  4. If you have any 64-bit applications that require Oracle, then install 64-bit Oracle client now (but not before installing the 32-bit client)
  5. Install BO Client Tools

joepeters :us: (BOB member since 2002-08-29)

I would also review the environment variable on the server to see which version of Oracle is being called

And I would also restart BO Services via the SIA after installing Oracle clients


jemstar :ireland: (BOB member since 2006-03-30)

Hi Joe,

I will give that a shot as soon as I can. I’m knee-deep in some Universe work. I’ll keep the 64-bit Oracle client with the BO Server installation on our Windows, and do everything you suggested on my client machine.

Hi Jemstar,

The environment variable is calling the 64-bit Oracle client on the server. I will reboot the entire server after I do the client updates on my laptop.

Thanks for the suggestions guys! Crossing my finger this works.


indy (BOB member since 2004-04-08)

Thank you all so much! We finally got it working! 64-bit on server, 32-bit on local machine :slight_smile:


indy (BOB member since 2004-04-08)

Hi Indy- am having the same issue with my designer client in my desktop. Basically I was trying to get 64 bit client for Toad and uninstalled 32 bit client. After realizing that designer needs 32 bit client, we got it back and uninstalled 64 but. Since then It’s unable to connect or locate the 32 bit oracle client. Environment variable is good. I was able to verify oracle client installation is good. Can you please explain what worked for you? Did you just follow Joe’s suggestion?


Sudkrish (BOB member since 2020-02-13)