BusinessObjects Board

Old VBA Code stopped working - ActiveX Errors

I have had a side-by-side of the BOBJ 3.1 FP7.2 client tools and 4.2 SP5 Patch 1 client tools for almost a year. In the process of doing a migration from DeskI to WebI.

In this, I had built a macro in DeskI VBA which itterated through a set of reports and pulled out their query count, types, report tab count, etc…

This worked fine until this weekend when an admin decided to install the SAP Data Services 4.2 SP12 client in the same location which isn’t compatible with 4.2 SP5.

Afterwards when we tried to run the macro we get an ActiveX can’t create object error when Creating the session object. Something simple that worked before. I even tried to rewrite it to force the version 12 and same. So I figured the library registrations for 3.1 got messed up.

We removed the Data Services client and repaired both the 3.1 and 4.2 installs, but it still seems like it didn’t register the components properly again.

I have even tried to re-write the code in VB.NET using the .NET assemblies for the session management and it fails there as well.

I have run a gacutil -i and regsvr32 on all the dlls in the dotnet folder but not sure what other registrations I am missing.

Any idea how to get at least the ActiveX components and dependencies to register again properly or have run into this before and how to fix it?

Thanks in advance.

ntruhan (BOB member since 2015-07-14)