BusinessObjects Board

LOV settings now greyed out in Designer

We’ve recently upgraded from BO4.3 SP1 to BO4.3 SP9 and around the same time I’ve noticed that all of our .unv universes within the Universe Design Tool (existing and new) have the option to assign / unassign Lists Of Values greyed out. It’s every universe I look at and they definitely did have this option available previously. It seems to be automatically assigning LOVs to dimensions and not assigning LOVs to measures, so even though it’s greyed out, it’s mostly working as you’d expect; however, it means I don’t have the option of removing LOVs from things like timestamps, where we don’t want a List of Values to be generated. It feels like a server-side issue (because it’s all universes, so unlikely to be something at the universe level) but our server support guy is relatively new and the functionality shouldn’t have changed during the Service Pack upgrade, so we’re both a bit stumped about what to look at in order to restore this bit of functionality. Any ideas of thing to check, most welcome!
LOV Screenshot|448x499, 50%

You might want to check you version information. There is no service pack 9 for BI 4.3. It is only as far as service pack 2.

We are working on an upgrade from BI 4.2sp8 to BI4.3sp1 patch 8. I checked one of our unv universe and the “Associate a List of Values” option is not grayed out. This is true for dimension objects, measure objects, and detail objects.

Ah okay, it’s obviously a patch number and not an SP number and I’ve picked up the wrong info. Apologies, will check and edit the post.

UDT is a client tool, so it’s unlikely to be a server issue. Did you update the client tools to the same version as your BO platform when you did your update?

PS… UDT is being deprecated. You should consider migrating to IDT.

Thanks for the replies and apologies for the delay - annual leave. The client Designer tool is the same SP/patch as the server. It’s version 4.3 Support Pack 1 Patch 9. Version:

Just to give an update on this, my admin guy (I don’t have access to the CMC) identified a permissions issue on every single universe post-migration. I have no idea how it happened, nor does he, but he’s reset some user permissions on one universe and the LOV option is no longer greyed out. (The ‘View Table Values’ option was also greyed out and his fix has sorted that too). So he’s going through every single universe resetting the user permissions. I have no information on what caused it but figured it was worth posting the final update. Thanks to everybody who commented.

The closest right that I can see that would match you not being able to select the LOV would be the “New List of Values” Universe permission.

The “View Table Values” option is easier as there is a “Show Table or Object Values” Universe permission.

Glad you issue is resolved.