Logon failed for RESTful Web Services - need https on WACS

Hi all, I have a new build of BI4.3 and have come up against this issue.

When I set the http URL in ‘Applications…RESTful Web Service’ I can login to the BI Launchpad fine.

I have an SSL certificate for the FQDN and have successfully deployed it on Apache Tomcat. The CMC is fine when using https but the Launchpad throws up the error ‘Logon failed for RESTful Web Services’ which , I presume, is because the RESTful web service also needs to be on https.

There is a setting for this in the ‘Web Application Container Service’ in the CMC but I cannot get it to take the SSL certificate and start the https service. It just comes back with an error - ‘cannot start https service’

info: I generated the certificate against the domain name not an IP address using Letsencrypt. I have a PKCS12 certificate which I converted from the .pem version.

Has anyone managed to configure https on WACS successfully? If so, how?

Thanks in advance

In BI4.3, the RESTful web service is hosted in Tomcat. You don’t need to configure anything in WACS for it.

All we had to do is configure HTTPS for Tomcat.

Check the URL that is configured for the RESTful web service in the CMC. This is the URL you should be using.

JohnBClark, thanks for getting back so quickly.

I’ve configured Tomcat to use the .pem certificates and I can connect successfully to the CMC with https. So I think I’ve done the right thing there. (I should clarify that I need these web applications to be accessible across the internet and not in a private , company network. Hence the FQDN. The domain is being handled by a web hosting company and is pointing to the public IP of the server. I have port 443 for https and 6405 for the RESTful web service open on the firewall. )

When I configure the RESTful web service in the CMC to use the FQDN (e.g somedomainname.com)


I get back an ‘infostore’ object as an answer and this I presume means its connecting to this service ok.

I then try to login to the BI Launchpad


and I get back the ‘Logon failed for RESTful Web Services. Contact system administrator.’ error.

If I just use the server name within the network where the server resides I can connect ok:


If I stop the Web Application Container Server in the Servers on the CMC I get the RESTful error message again which is why I presumed it was running the RESTful service needed as part of the login process.

Sorry about the length of the reply. I hope that makes sense.

Did you try adding your port number to this configuration?

JohnBClark, thanks . Yes, If I put in the https port (443) the browser just defaults back to the URL as https has 443 as the default port no.


becomes …https://somedomainname/BOE/BI

OK. I was thinking of the default port for the RESTful web service. Not the default port for the BI Launch Pad. But there isn’t a place to specify a port for the RESTful web service with the link as far as I know of. I’m not sure I know what your problem might be.

I am testing BI4.3 now and our is working fine without any modifications other than what we had for BI4.2.

Thanks for your suggestions. Actually you did help me. You got me thinking as to why its fine on your deployment and not on mine. I had a google and came up with an article that states that states SAP made a change from 4.2 onwards that deployed the RESTful service through WACS and Tomcat - running side by side as two alternative ways to access it. This would explain why quite a lot of the posts on this that I have read, kept saying to put 8080 in the RESTful service URL ( in cmc…applications’). I am investigating this now…


Thanks to John B Clark for pointing me in the right direction. Here is the solution:

Background info: SAP updated the software so that that RESTFul service could be reached in 2 ways. One - by the WACS which appears in the installation wizard and has a default port of 6405. Two - as a Tomcat application at port 8080. For some reason I don’t understand the Tomcat version was not automatically also deployed during the installation. Therefore I could see the service at port 6405 (http://somedomainname.com:6405/biprws) but when I tried to also access it through port 8080 (http://somedomainname.com:8080/biprws) I got nothing back. This would have been fine except I needed to access the BI Launchpad using https. I had configured Tomcat to use https but when I tried to login to the BI Launchpad it gave me an error as it couldn’t find the RESTful service at port 8080 or 443 (the https port).


  1. (I probably overegged it a bit but) I used WDeploy to redeploy all the web applications from scratch.This promptly broke access to the CMC and BI Launchpad
  2. Went to the Tomcat web apps folder (C:\Program Files (x86)\SAP BusinessObjects\tomcat\work\Catalina) , renamed localhost to localhost_old and restarted the Tomcat server which forces a redeployment of the WAR files
  3. Hey presto ! The RESTful web service now returns an answer when I use port 8080.
  4. Edited the Tomcat server.xml file in the conf directory to redirect port 8080 to port 443.
<Connector executor="tomcatThreadPool"
               port="8080" protocol="HTTP/1.1"
               redirectPort="443" />
  1. In the CMC…Applications I changed the URL in the two web services that are needed
    a. RESTful Service now used https://somedomainname/biprws
    b. Web Service now used https://somedomainname/dswsbobje

Restarted the whole lot and that seemed to fix it. I can now access and login successfully to the BI Launchpad using https://somedomainname/BOE/BI

----END of Solution------

1 Like