IIS ASP possible issues - HTTP 404 and admin


I have Win 2003 systen and I have BO installed in simplest way with IIS and ASP.
ASP was chosen because BO during installation rejected to automatically recognize 3 Tomcat installations I have on this box so to be on safe side I went with ASP.

Now I have entire system working almost OK. I can create universes, I can post documents and if I go no /wiasp site i can login, can see names of my posted documents. However if I CLICK at any document I posted from ‘My Infoview’ or from search pabe in ‘Home’ screen all I get is HTTP 404 screen. I looked into logs but it is not much help - as can be see from below cut /wiasp/bin/iswi.dll/cookie/wiqt/ is the one that generates 404 error. Amazingly in any other log i looked at I see no errors or anything else. What should I do and what can be the problem?

Another problem I cannot explain - if I go into EXE Administration Console - it works fine. But Admin console at /wiadmin web site simply spits out ‘system is not started’ error adc 00071. Again, I cannot figure out where to look for errors.

I did not have to support this before and hope someone here can give me a hint. Very confusing system, I have to say.

2007-12-18 19:29:59 W3SVC1 DEMOSRV GET /wiasp/images/skin_default/doc_anim.gif - 80 - HTTP/1.1 Mozilla/4
.0+(compatible;+MSIE+6.0;+Windows+NT+5.2;+SV1;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727) demosrv 200 0 0
2007-12-18 19:29:59 W3SVC1 DEMOSRV GET /wiasp/bin/iswi.dll/cookie/wiqt/queryTechnique/GetDocument sEntry=wi00000001&sF
orceRefresh=N&sOpen=Y&DocumentName=TUTORIAL&DocumentId=11&sHTMLPath=/ 80 - HTTP/1.1 Mozilla/4.0+(compatible;+MSIE+6.0;
+Windows+NT+5.2;+SV1;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727) demosrv 404 2 1260
2007-12-18 19:30:34 W3SVC1 DEMOSRV GET /wiasp/scripts/login/webiHome.asp - 80 - HTTP/1.1 Mozilla/4.0+(co
mpatible;+MSIE+6.0;+Windows+NT+5.2;+SV1;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727) demosrv 200 0 0


as i see admin module also seems to give 404 error on dll.
2007-12-18 19:45:58 W3SVC1 DEMOSRV GET /wiadmin/bo/wi/adapter/SiteManager$LocDataFile.class - 80 - HTTP/
1.1 Mozilla/4.0+(Windows+2003+5.2)+Java/1.6.0_03 demosrv 304 0 0
2007-12-18 19:45:58 W3SVC1 DEMOSRV POST /wiadmin/bin/admisapi.dll Module=SiteManager 80 - HTTP/1.1 Mozil
la/4.0+(Windows+2003+5.2)+Java/1.6.0_03 demosrv 404 2 1260

is it something about security in IIS? but i have allowed access to scripts for that site. what else should be set?
i found that 404-2 error description - ‘not found - denied due to lockdown policy’. What the heck is this?

utkinpol (BOB member since 2007-12-18)

thanks for nothing. i fixed it myself.

utkinpol (BOB member since 2007-12-18)

Please be patient! :roll_eyes: All of our members are volunteers and only log on once in a while. We’re a community of users helping each other out when and if we can.

Even if you submit a case to tech support (for which you pay), you often don’t get a call back for a day or more. So not getting a reply in an hour is nothing to be surprised about.

The normal protocol is that you should wait a day or more. If you haven’t gotten any replies, then you can “bump” up the topic by adding another post, to put it at the top of active topics. :wink:

Anita Craig :us: (BOB member since 2002-06-17)


I am also getting similar issues: How did you fix it?


Kaashi :india: (BOB member since 2004-10-05)


I now that this is a old post but myself I hate it when nobody post the solution after fixing this.

This is the solution I did find for this error:

In IIS add a webservice extension:
BusinessObjects WIADMIN
At required files add the /wiadmin/bin/admisapi.dll
Select the check box for Set Extension status to allowed.

This solved my issue for :wiadmin ‘system is not started’ error adc 00071

One other issue can be that you need to enable Parent Path support in IIS.

Best Regards,

ArjanF (BOB member since 2007-07-04)

I have the same issue. i followed what you suggested - adding the .dll to web extensions and setting it to allowed.

Should I restart IIS 6 for this to be recognised? I had tried adding some other .dlls for some other issue and restarted the IIS, but it didn’t help.

Please let me know if you remember what you did .


User@BO (BOB member since 2012-07-23)