BusinessObjects Board

How can you change the document owner in the repository?

Hi All,

How can you change the document owner in the repository (apart from manually import then export the document as the new user and making sure the new user has the right to overwrite an existing document he does not won) ?

I am sure I am not the only one to face that problem ?

Thanx


fguionne :fr: (BOB member since 2002-08-16)

Well, you can delete the user who originally sent the report and ownership will be transferred to the original General Supervisor. That’s probably not at all helpful but I thought I’d throw it out. :crazy_face:


Cindy Clayton :us: (BOB member since 2002-06-11)

The only way I know to do it, is by modifying the tables in the repository.

Not Supported of course.


Hayden_Gill :australia: (BOB member since 2002-08-15)

Ok,

Modifying M_DOC_N_USERID in OBJ_M_DOCUMENTS does the trick ?

Have you personnally tried it Hayden_Gill ? (If you did, then I guess there should be no side effect)


fguionne :fr: (BOB member since 2002-08-16)

Didn’t realize this would happen before I deleted my userid. :blue: Now I want to republish some of the reports I owned and I can’t overwrite the existing reports. :reallymad: What are some of the ways I can republish my reports?

Thanks


John Phillips :us: (BOB member since 2002-10-01)

Give yourself the proper permissions in Supervisor. I think it is the Reporter permission 'Delete corporate documents sent by other users.


Cindy Clayton :us: (BOB member since 2002-06-11)

That’s enabled for me. So you’re saying don’t mess with trying to change ownership, just delete and republish?


John Phillips :us: (BOB member since 2002-10-01)

No I wouldn’t delete it. I thought that might be the permission that controls overwrite ability. What message do you get when you try to publish? That might help me remember the permission.

Are you in multiple groups with battling permissions? If you’re in two groups and one has that permission set to disabled and the other to enabled, disabled wins.


Cindy Clayton :us: (BOB member since 2002-06-11)

Just one group. The first message I get is something like “the report already exists, would you like to overwrite?” and I say yes. Then I get a second message that says something like “you cannot overwrite the report,” but nothing more specific than that. I was thinking maybe it had something to do with the owner changing to the original GS and not being able to touch their stuff, ever.


John Phillips :us: (BOB member since 2002-10-01)

I don’t think so but I could be wrong :mrgreen: . I thought that was it. There definitely is a permission. Poke around in there and post back when you find it :yesnod: .


Cindy Clayton :us: (BOB member since 2002-06-11)

Are you web publishing? If so, try disabling ‘Do not delete others…’ in the Webi permissions. Nothing like consistency huh :wink:


Cindy Clayton :us: (BOB member since 2002-06-11)

Yes and it is.


John Phillips :us: (BOB member since 2002-10-01)

Ok…tried one more time to republish and I misread the message I’m getting. :oops: Sorry about that; you have permission to shoot me.

The message actually reads:

Cannot delete previous document; document not exported. (DX0030)

Based on the error message guide, I don’t think this problem is related to the ownership at all. I think it may just be a coincidence that the problem occurred around the same time I recreated my userid. I’ve never received this error message in the past. :reallymad:


John Phillips :us: (BOB member since 2002-10-01)

Tried again this morning and everything is functioning normally again eventhough I didn’t change a thing. :crazy_face: :crazy_face: I think I’m starting to go insane. (-:

I apologize if I got off course for this topic.


John Phillips :us: (BOB member since 2002-10-01)