BusinessObjects Board

Error while running webi reports on new laptop

One of our users has installed Webi rich client on his new laptop ,XI 4.2 sp7. The user has full rights ,however, when he tries to refresh the reports either on webi rich client or Bi launchpad, he gets a warning -You don’t have rights to access the data on this connection or the connection is not defined.
What could cause this problem?

Sounds like row level security to me. Take a look at the universe and row security. Make sure the user is in one of those groups.

Did you try to add link to the host file ?

Host file was the first thing i checked ,but it has alreadty been added Also it’s a free hand sql. User can execute the query at the back end. The problem is with BO reports. Also, when the user clicks on edit sql ,it just sits idle endlessly and does not throw any error.

1 Like

Go into CMC, go to connections, select the connection used by the Webi document, right-click and select user-security. Now add the user group that the user belongs to, or make sure that they aren’t inadvertently a member of a group explicitly banned from that connection.

Thanks Mark. .That does not seem to be the issue, because these settings are already in place. We have now raised it with SAP and waiting for them to revert.

What type of connection is being used? Is he using a universe or free hand sql? If he uses a different machine does he get the same error? If you, or someone else, uses his machine, can you connect? – That will help diagnosis machine/software issue vs user issue. If it was just the rich client, I’d say check that the correct version of the database client is installed, any data source names exactly match, etc. But, if he’s also having issues in LaunchPad, that points to user/security issue since it should be using all from the server vs local.

It is a free hand sql as mentioned earlier in this post. The only thing is the user switched over to a new place so using a new laptop with the same settings . He and others can open the report in webi as well as launchpad ,but the problem is no one can refresh the report nor create a new one. Is there anything apart from host file and CMC settings that we are missing out?

Is the user an administrator on his new laptop?

Long time ago but 6.5.1 had issues with new installs where BO needed the user to have admin rights on their own PC to install client tools properly. That wasn’t the case for XI2 & XI3 but parts of it may have crept back in?

No he is not. But none of us can run any query on his laptop which is weird because as i mentioned earlier, everything is in place. We are unable to find out a way, so raised a ticket with SAP. I hope they fix it soon. Thanks a lot.

Still sounds like a CMC issue to me.

There are application settings around this in webi - “but the problem is no one can refresh the report nor create a new one” points to this. CMC → Applications → WebIntelligence and check user security. Make sure they have the right “Documents - Enable Creation”.

Are you logging into both the laptop and LaunchPad as yourself when verifying the issue on his machine? If he uses a different machine does he have the same issues? Can he run the SQL using SSMS or another query tool on his laptop? What browser is he using? Any add-ons installed? Have you tried the browser’s safe mode or a different browser?

He can log on to other’s laptop and run/edit the reports. We have tried using our ids on his new laptop , we get the same issue. As far as Sql is concerned, we are using Oracle as the db and there is no problem connecting to the db and executing the query. Browser and webi rich client both of them give the same problem on his system.This definitely sounds crazy as we have not been able to fix this issue till date,
In fact , he also uninstalled and reinstalled BO on his system. We have not checked the add-ons or any other software that could cause this problem .

How are you authenticating to the database in the Connection on the BO server? Is it a pre-set user/pword used by everyone or is it passing in credentials?

We have to enter our credentials to connect to BO server. I don’t think this has got anything to do with Bo settings . This should have something to do with the laptop settings or may be there is some conflicting software.

New info in that bit. Definitely something wrong with the way BO is set up on his laptop.

Is the laptop on a different domain to the webi server?
Anything else different about the laptop and how it connects to a working one?

Don’t mean how do you connect to the BO server. I’m asking about the database connection that is configured in BO - the connection that you select prior to creating your FHSQL connection. There are settings in the connection for how you authenticate to the database. It can be set to a specific user, to pass thru your credentials, etc. If it’s passing thru the credentials, that may be the problem - i.e. it’s connecting to a different domain that doesn’t have access to the database server.

When using WebI, the only settings on the local machine that should be used are network related. You could completely remove the BO client software and LaunchPad and WebI will still work.

Our license expired today ,so it was again renewed in an hour’s time, after which it started working on the user’s new laptop. Finally it got resolved. Thanks to all of you for your support.

1 Like

Wait… what??? What would a license that expired TODAY have to do with a user not being able to edit or run FHSQL for the past 2 weeks when the license was still valid? And since when do you have to have a valid support license to continue using BOE?

This ‘solution’ is more concerning than it not working to start with!!! I’d be pressing SAP for an explanation BIG TIME!

1 Like

We have been using SAP BO for many years ,never came across this kind of problem earlier. The implementation team is looking into this. If this is some kind of restriction from SAP then definitely they are holding us to ransom, if not then it becomes even more challenging to find out the cause.