Error 1112339 when import a metadata table from SAP R/3


When I imported a SAP metadata which include a column having data type - character string of variable length, DI receive the error BODI -112339; Error: Cannot import the metadata table. Parser detected an unkown data type. Please notify Customer Support.

Your help would be much appreciated.


shaoliwen (BOB member since 2009-08-24)

What table or structure you are trying to import from SAP. Why dont you check the table/structure properties in SAP?

SantoshNirmala :india: (BOB member since 2006-03-15)

The table is ZNPCP_EVENT_REAS. the data type in SAP is charater string of variable length. Please let me know if you need more information…

shaoliwen (BOB member since 2009-08-24)

A variable length string is common, it has to be something else.

Werner Daehn :de: (BOB member since 2004-12-17)

I asked an ABAP programmer to create a test table without data type String(0) and I am able to import the table metadata successfully. Then I asked her to add a new column with data type String(0), and I failed to import it.



shaoliwen (BOB member since 2009-08-24)

String of length 0 is rather short, isn’t it?

Werner Daehn :de: (BOB member since 2004-12-17)

According to my ABAP programmer, it is charater string of variable length. I just wonder if you are are able to import a meta data table with this ind of data type.

shaoliwen (BOB member since 2009-08-24)

A string(100) is variable length as well, but with a max length of 100 chars. string(0) is not very common and as it seems DataServices has a problem with that.

Werner Daehn :de: (BOB member since 2004-12-17)

Any walkaround?

shaoliwen (BOB member since 2009-08-24)

I’m also struggling with this. I have imported some 20 tables succesfully, but after changing the settings for the following parameters it gives me the error for each table, even those imported successfully before:

  • Working directory on SAP server
  • Application path to the shared directory
  • Generated ABAP directory
    These settings are correct as I can execute ABAP dataflows from tables that are already imported. Reimporting tables however, removes them first and then gives this error.

Badly need some help on this… :hb: :reallymad:

lamanp :netherlands: (BOB member since 2008-09-02)

… and those settings are not used during the import table. Has to be something else.

I would start with logging in to SAPGUI using the same user as in the datastore, run transaction /nse37, type RFC_ABAP_INSTALL_AND_RUN, click on execute to get into the execution dialog and then execute.
If everything is in order it will say: “Error when executing, no input provided” or something and that’s true, we haven’t filled out anything the execution dialog.

But if my assumption is right you would get a permission error in SAP somewhere along the way.

Werner Daehn :de: (BOB member since 2004-12-17)

We did some more tests and it now appears to be so that I can import any table from ECC until I try to import table REPOSRC. This table contains a column with data type RAWSTRING(0), which means it has an infinite length. We tend to draw the conclusion that this causes the problem and breaks something in my client. After the attempt to import this table, I cannot import any table from ECC anymore until I exit the Designer and restart it. Sounds like a bug to me. :crazy_face:

lamanp :netherlands: (BOB member since 2008-09-02)

Hi All,

After couple of years, I am getting same error as specified below.

We are trying to import few SAP ECC tables - WBHI and WBHK, and we are getting this error.
Do we have a solution for this?


d.ravikiran2009 (BOB member since 2011-02-16)

It seems that in the latest version, you can import the table at least. But still not read those fields (you have to leave them out in your query transform)

ScSi :belgium: (BOB member since 2013-10-08)


Anyone managed to resolve this issue.

We are having the problem when we tries to import a table from cSAP. We have already imported and used over 50 tables from the system, but wheth we tries to import KONV, we get the error.

KONP, KONH imported successfully.



amuh10 :uk: (BOB member since 2012-04-11)

We have other SAP systems, iSAP, and SAP r/3, and we can import the same table from these systems successfully.

amuh10 :uk: (BOB member since 2012-04-11)


did anyone resolve this issue?. I am getting this error while importing KONV table from ECC?


DbUoRdAsI :india: (BOB member since 2012-05-08)

HI Team,

I am facing the same problem as above. If any one of you find the solution to the given problem, please let me know.

I have an alternative solution to change the data type using ABAP and then use it as a extractor.

But please let me know if I could do this without using ABAP.

Amitkumar Gupta

amitkg87 (BOB member since 2017-07-24)