Default BOXI 4.2 to SQL 206 connectivity

Hi

I recently posted about connecting from SQL 2014 from BOXI 4.2

We’ve changed a few things round after getting no further.

Its now SQL 2016 and we have updated to BOXI 4.2 SP7.
The SQL Server had TLS1.2 active, the next steps were to remove the previous BOXI (SP5) and reinstall SP7.
Minimal BOXI configuration was done. We used BOXI Tools to change the DB Server name and tried connecting … all OK

Then tried to connect to the reports and then the dreaded SSL error appeared again. What I don’t understand is the users laptop has Oracle SQL Tools on it and that can connect to the database and view data inside the tables without any issues whatsoever,
What would drive this SSL requirement ? the SQL Server ? I suspect so as its not possible to disable TLS 1.0 / TLS1.1 and TLS 1.2 the SQL Service simply won’t start. Any ideas what would cause that to be the case ? my SQL instance has no TLS on it at all and no problems there.

Cheers Steve


stevem :uk: (BOB member since 2008-10-27)

Try updating your SQL Server Native Client 11 drivers. There is a newer version (2011.110.7001.00) out that has support for TLS 1.2. We had to update our drivers.


JohnBClark :us: (BOB member since 2007-03-27)