BusinessObjects Board

Custom fonts missing after 4.2 SP9 Patch 13 install

All custom fonts defined for WebI appear to be missing after upgrading the environment from BO BI SP9 Patch 3 to BO BI SP9 Patch 13. The most important/used font, “Code39AzaleaWide2”, used for barcode printing is the best example.

All custom fonts worked before the upgrade.

The font is installed on the server running the SIA. It is also installed on the end-user machines running the report.

The relevant section is here:

  <FONT NAME="Code39AzaleaWide2">
	<FONTFAMILY PLATFORM="ttf" NAME="Code39AzaleaWide2">
		<FONTATTRIBUTE BOLD="false" ITALIC="false" LOGICAL="Code39AzaleaWide2" PHYSICAL="Code39AzaleaWide2.ttf"/>
	<FONTFAMILY PLATFORM="win" NAME="'Code39AzaleaWide2'"/>
	<FONTFAMILY PLATFORM="java" NAME="'Code39AzaleaWide2'"/>
	<FONTFAMILY PLATFORM="html" NAME="'Code39AzaleaWide2'"/>

The file is located here:
C:\Program Files (x86)\SAP BusinessObjects\SAP BusinessObjects Enterprise XI 4.0\win64_x64\fonts\fontalias.xml
C:\Program Files (x86)\SAP BusinessObjects\SAP BusinessObjects Enterprise XI 4.0\win32_x86\fonts\fontalias.xml

The font has been installed on the Windows serevr running SIA. The font appears in c:\windows\fonts with teh same spelling.

Both SIA and Tomcat have bee restarted multiple times.

I even tried to clear the cached contents of all web applications by deleting everything in the “work” directory under tomcat and having tomcat rebuild just in case something was “stuck”. No change to behavior.

The steps in “2115076 - Troubleshooting barcode fonts not displaying in Webi reports” have been followed with no change in behavior. The single and double quotes were already in place.

When looking at the list of available fonts it is just the out of the box options available.
WebI font list

Chrome version: 112.0.5615.138 (Official Build) (64-bit)
Edge Chromiun version? 112.0.1722.58 (Official build) (64-bit)

This worked before the upgrade. I believe it was working under 4.2 SP9 Patch 12 as well but I only tested that on one environment before moving to SP9 Patch 13.


The Rich Client Editor is working and displays all the custom font options.
[I will add a picture when allowed to. Account too new.]

WebI still impacted however.

Any thoughts on what to check next?

Solution: Fonts have been moved to fontalias_v2.xml. This file was introduced in SAP BO BI 4.2 SP9 Patch 12.

SAP KB article “3121685 - Customized fonts stop working after SAP BusinessObjects Business Intelligence Platform 4.3 Support Pack 02 is installed”, 3121685 - Customized fonts stop working after SAP BusinessObjects Business Intelligence Platform 4.3 Support Pack 02 is installed | SAP Knowledge Base Article, led to figuring this out even though my instance is 4.2 instead of 4.3.

I found nothing in the 4.2 SP9 release notes about this change in behavior.