BusinessObjects Board

CCM Crash with getting libOCAHelperw-5-0.dll after downgrade Service Pack Version BI 4.3 SP04

We had done upgrade on our BO DEV server from BI4 .3 SP02 Patch 10 to BI 4.3 SP04 for POC. So, after few days testing we finally conclude to downgrade the application and come back on the same earlier version(BI 4.3 SP02 Patch 10)

So, we did uninstallation of BI 4.3 SP04 and it completed successfully. Then I followed below steps and found the issues.

Now we are getting library error while accessing CCM. Tomcat is working fine and URL is accessible but SIA is not working because CCM is not accessing,


Here are the steps we followed.

Sr.No. Steps process
1 Uninstalled BI 4.3 SP04
2 Uninstalled Microsoft Visual C++ 2015-2022 Redistributable (x64) - 14.38.33130
3 Installed Microsoft Visual C++ 2015-2022 Redistributable (x64) - 14.29.30130
4 Restarted the server
5 CCM Open
6 Tomcat Running status
7 SIA Stopped status
8 Unable to start SIA
9 Uninstalled BI 4.3 SP04 Client Tool
10 Client tool uninstallation stuck-Start Server Intillent application- More than 5-6 hours
11 Kill the installation setupengine.exe
12 Rebooted server
13 Uninstallation start from base client tool…but got error "Installer has detected that a previous operation did not completed. DO you want to resume?
14 Followed SAP KB resolution
15 Then client tool uninstalled successfully completed
16 Then rebooted the server
17 Tried to access CCM, but SIA was not starting up
18 Then Repaire process start on BI server base version
19 Repaired completed successfully.
20 Then rebooted the server
21 Tried to access CCM, but started getting svcmgr.exe entry not found error
22 Then started getting error libOCAHelperw-5-0.dll not found

Can someone aware of this scenario to recover CCM?


why did you mention Client-Tools ?
did you install them on this Server ?
this is not recommended and can lead to problems due to duplicate or incompatible files.