4.2 SP06 > 4.3 SP01 Issue

Around 8 hours ago i took the decision to upgrade to 4.3. Unfortunately ive hit an issue and i cant work out where its gone wrong.

I first installed 4.3 SP0, server and client tools, managed to get the CMC to work and ensured the relevant servers are working (Webi, APS etc). I cant seem to get Webi to fire up and im getting a 404 Missing Page Error…

’ 404 Missing Page

The page you requested is not available on this web server for one of the following reasons:

** The address you typed may be inaccurate. For example, a character was missing. To correct this issue, double-check the address and make sure that it is spelled correctly.*
** If you clicked on a link or button, the web application that generates this link may be experiencing a temporary problem. Close and restart your browser and try the link again at a later time.*

After verifying that the error is not the result of a bad address or web application problem, perhaps the page you tried to access may no long exist or can not be generated. Report this problem to the webmaster or the administrator.

If you are the webmaster or the administrator of this web server, refer to the SAP Business Intelligence Suite Error Messages Explained Guide for more suggestions.

If the problem still persists, please:

** Search the SAP BusinessObjects Knowledge Base Articles for similar cases.*
** Contact with SAP BusinessObjects Customer Support.’*

I thought something must have gone wrong with the install and perhaps that by installing 4.3 SP1 Patch 0 it might repair any issue. I did this but its still the same Its now 00:24 in the morning and i need to get this resolved before Monday.

Any advice would be much appreciated!

Haven’t updated to 4.3 yet but did have a similar issue when I updated to from 4.2 SP08 P01 to 4.2 SP08 P06. CMC worked, all the servers showed as running but was getting unable to connect errors for LaunchPad.

Issue was with the server.xml file (C:\Program Files (x86)\SAP BusinessObjects\tomcat\conf\server.xml). Settings for both HTTP and HTTPS were turned off/commented out. Also noticed the parameters had changed in the disabled block from what we had previously used. Copied the HTTPS setting from a back-up copy of the prior file and viola, everything worked.

Not sure if 4.3 uses the same file, but it’s something to check out.

Thank you for your response.

I did come across a blog last night that said the following…

The version of Tomcat changes to Tomcat 9.0.26.

This will have impacts on changes you have made to your server.xml for instance to change port numbers, SSL, etc.

It will also have impacts on any other customisation you have done under %INSTALL_DIR%\SAP BusinessObjects\tomcat\webapps

*This may have an impact on your SSO and also your .properties if they only reside in in %INSTALL_DIR%\SAP BusinessObjects\tomcat\webapps\BOE\WEB-INF\config’

So i had already seen there may/will be changes to the server.xml file. I note that in the tomcat conf file i have a number of previous versions (.backup .old) of the server.xml file. One of which looks at about the time the install was getting going. That said ive compared that against the current live XML file and they appear to be the same.

Can i just check that you got your fback up from the same place that im looking rather than a copy from a snap shot prev start of your install?

Ive since managed to get Rich Client 4.3 working on the server, however Webi is still showing the 404 error

I always make my own backups of files that I customize plus have notes on the changes, so I used my copy as the original source.

If the date on the file is from when you did the upgrade, the old file is probably the copy backed up by the update. Make a copy of the current file, just in case, then replace the http and/or https section of the new file with those sections from the old. You could try replacing the entire file, but there may be other changes that you don’t want to over write. If it doesn’t work, you can always restore the new version from the copy you made.

RC doesn’t use Tomcat, or hasn’t in the past, so not surprised it’s working.

sorry, can’t help with your problem
but I’m curious why are you starting with 4.3 SP0 although there is 4.3 SP1 Patch 9 available ???

I’ve tried rebuilding the localhost file but still the same issue. I’ve since rolled back to 4.2 until ive got time to look at this again.

@N8AKTIV we came across something that suggested that you should install the base install first and SP on top of it. In hindsight i think this is just for the initial BO install and i understand that we could have gone straight for 4.3 SP1 Patch 9