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Crystal Enterprise 

Installing and troubleshooting the Active Directory Plug-in 

Overview 
This document explains what is required to use Active Directory Plug-in, 
secWinAD.dll, with Crystal Enterprise 9. This document examines how to 
troubleshoot potential problems and common scenarios regarding scalability and 
performance. 

Although this document has been written for Crystal Enterprise 9, it can apply to 
Crystal Enterprise 8.5. Step-by-step instructions may be different between 
versions. Consult your product documentation. 
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Introduction 
Read this document to understand how Crystal Enterprise 9 uses Active 
Directory. This will help you to avoid potential issues and to troubleshoot 
scenarios that you are experiencing. 

Background 

What is Active Directory 
Crystal Enterprise 9 is capable of using Active Directory to authenticate users 
through its Automated Process Scheduler (APS) service. Additionally, Active 
Directory groups can be imported into a Crystal Enterprise system.  

Active Directory is a technology included with Microsoft’s Windows 2000 
Server and Windows 2003 Server. Active Directory is used to manage network 
users, computers and resources with a lightweight directory access protocol 
(LDAP) database. Management and administration are centralized when using 
Active Directory compared with previous versions of Windows server products.  

For more details on Active Directory technology, click here for related 
information on the Microsoft Technet site: 

www.microsoft.com/technet 

The Active Directory Plug-in for Crystal Enterprise 9 – secWinAD.dll – allows 
you to map users and groups from your Microsoft Active Directory 
implementation to Crystal Enterprise. If the users specify Active Directory 
authentication type in Crystal Enterprise, the Active Directory LDAP database 
will authenticate users before the Crystal APS service grants the user a session 
which is needed to access its resources.  

Installation Considerations 
Where to find the Active Directory Plug-in download 
To download the Active Directory Plug-in for Crystal Enterprise 9, click the file 
name, ce9_adplugin_en.zip, or search for it on our support site at: 

http://support.crystaldecisions.com/search 

Before You Install 
Before you install the Active Directory Plug-in for Crystal Enterprise 9, consider 
all of the following: 

• You must log onto the computer as a local administrator. 

• You must have installed Crystal Enterprise 9. 

• You must install the plug-in on the server with the Automated Process 
Scheduler (APS) and the Web Component Server (WCS). If the APS and 
the WCS are on separate servers, you must install the plug-in on both of 
these servers. 

http://www.microsoft.com/technet/treeview/default.asp?url=/technet/prodtechnol/ad/default.asp
http://www.microsoft.com/technet
http://support.crystaldecisions.com/communityCS/FilesAndUpdates/ce9_adplugin_en.zip.asp
http://support.crystaldecisions.com/search
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• You must read CrystalAD.pdf, which is zipped with the Active Directory 
Plug-in download, for detailed instructions on setting up and mapping 
Active Directory groups. 

Background 
The EnterpriseFramework.dll is an essential file for the operation of the Active 
Directory Plug-in. The EnterpriseFramework.dll works in conjunction with 
secWinAD.dll and is installed with either the WCS or APS. This file must exist 
on the computer in order for the Active Directory Plug-in to work. By default, 
the file location is: 

c:\Program Files\Crystal Decisions\Enterprise9\win32_x86\EnterpriseFramework.dll.  

By default, the file location of secWinAD.dll is: 

c:\program files\Crystal 
Decisions\Enterprise9\win32_x86\plugins\auth\secWinAD\secWinAD.dll.  

Please note that this file must be registered successfully on install, so it is 
important that the account installing this have administrative privileges. 

Using Crystal Reports and Crystal Analysis with Active 
Directory Authentication 
If you are using Crystal Reports or Crystal Analysis Professional on your server 
with Active Directory authentication you should make sure that these are 
installed prior to installing the Active Directory Plug-in.  

Also, the Active Directory Plug-in needs to be installed on any client computer 
that will be accessing the Crystal Enterprise system through Crystal Reports or 
Crystal Analysis Professional that is using Active Directory authentication. 

During the Active Directory Plug-in installation, it writes to the registry to allow 
the option for Active Directory through the Enterprise Folders button in 
Crystal Reports and Crystal Analysis Professional from the File > Open dialog 
box. 

How to troubleshoot 
If you encounter problems after installing the Active Directory Plug-in for 
Crystal Enterprise 9, verify that all of the following conditions exist. 

What to Verify 
Enabling and Disabling Crystal Enterprise Services 
Verify that both the APS and WCS services are installed and running on the 
server. 

To verify that the APS is installed and running: 
Go to the Crystal Configuration Manager (CCM) to see if the service is running 
by clicking Start > Programs > Crystal Enterprise > Crystal Configuration 
Manager. 

To verify that the WCS is installed, running and enabled: 
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1. Go to the Crystal Configuration Manager (CCM) to see if the service is 
running and enabled by clicking Start > Programs > Crystal Enterprise > 
Crystal Configuration Manager. 

2. Select the Enable/Disable Servers icon on the toolbar. The icon has a 
depiction of a computer next to a checkbox. 

3. Log on with your Crystal Enterprise administrator user name and password. 
But default, the user name is “Administrator” with no password. It is 
strongly recommended that you change this as soon as possible for security 
reasons. 

Crystal Enterprise Service Accounts 
Verify that the APS and WCS services are running under a domain account with 
local administrative rights. 

To verify the local computer security policies: 
1. Click Start > Programs > Administrative Tools > Local Security Policy. 

2. Expand Local Policies and User Rights Assignment to ensure that the user 
has rights to: 

•  Act as Part of the Operating System 

• Log on as a Batch Job 

• Log on Locally 

3. Add the user to these rights assignments. 

NOTE Global policies override local policies. If you are having difficulty adding rights, contact 
your Network Administrator for assistance. 

 

If you are running your APS or WCS under a local system account, ensure that 
Trust Computer for Delegation check box is selected. If the service is 
configured to run under a local system account, the computer where the service 
runs must be trusted for delegation.  

To configure a computer account as trusted for delegation: 
1. In the Microsoft Management Console (MMC), right-click the computer 

object in Active Directory Users and Computers,. 

2. Click Properties and then select the General tab.  

3. Select the Trust Computer for Delegation check box. When you are 
prompted with a warning, click OK to accept it and click OK to apply the 
change. 

4. Properties and then select the General tab. Select the Trust computer for 
delegation checkbox. You will be prompted with a warning, so you should 
click ok to accept it and click ok again to make the change.  

NOTE For security reasons, it is recommended to use a domain user or service account rather 
than trusting a computer for delegation. This way, you can assign only the essential rights 
to the one domain user or service account. 
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DNS Suffix 
Verify that the Domain Name System (DNS) suffix is properly set to the Crystal 
Enterprise server computer. For detailed instructions, refer to our knowledge 
base article c2013161 on our support site at: 

http://support.crystaldecisions.com/search 

Figure 1: DNS Suffix 

 

Multihomed Computers 
Verify that the current computer is listed at the top of the binding order in the 
Advanced Settings dialog box. 

If you are using a multihomed computer (more than one NIC card is installed) 
with Crystal Enterprise, be aware that this could cause issues if the current 
computer is not listed at the top of the binding order dialog box. 

Verify that the current computer is listed at the top of the binding order in the 
Advanced Settings dialog box. 

For detailed instructions on using multihomed computers and changing the 
binding order, refer to the knowledge base article c2010587 on our support site 
at: 

http://support.crystaldecisions.com/library/kbase/articles/c2013161.asp
http://support.crystaldecisions.com/search
http://support.crystaldecisions.com/library/kbase/articles/c2010587.asp
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http://support.crystaldecisions.com/search 

Figure 2: Binding list 

 

Command Line Utilities 
Determine if network routers or subnets are experiencing network problems or 
determine what group policies have been applied to that account by using 
command line utilities such as: pathping and gpresult. 

Pathping: 
From www.microsoft.com, click here for more information on how to use 
pathping. 

“This command line utility provides information about network latency and 
network loss at intermediate hops between a source and destination. 
Pathping sends multiple echo request messages to each router between a 
source and destination over a period of time and then computes results 
based on the packets returned from each router. 

Because pathping displays the degree of packet loss at any given router or 
link, you can determine which routers or subnets might be having network 
problems.” 

Gpresult: 
From www.microsoft.com, click here for more information on how to use 
gpresult. 

http://support.crystaldecisions.com/search
http://www.microsoft.com/
http://www.microsoft.com/windowsxp/home/using/productdoc/en/default.asp?url=/windowsxp/home/using/productdoc/en/pathping.asp
http://www.microsoft.com/
http://www.microsoft.com/windowsxp/home/using/productdoc/en/default.asp?url=/windowsxp/home/using/productdoc/en/gpresult.asp
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“This command line utility displays Group Policy settings and Resultant Set 
of Policy (RSOP) for a user or a computer.” 

 

Group Policies 
Verify how Group Policy Objects are filtering down to a site, domain or 
organizational unit. 

For more details on how to find the sites, domains and organizational units to 
which a Group Policy object is linked, click here to refer to the related 
information on the Microsoft Technet site at www.microsoft.com/technet. 

Security Groups vs. Distribution Groups 
Verify that you are using the correct group type. 

The Crystal Enterprise Active Directory Plug-in – secWinad.dll – searches only 
for the Active Directory Security Groups. Distribution Groups are only used 
with email applications to send to collections of users. 

For more details on Security Groups versus Distribution Groups, click here for 
related information on the Microsoft Technet site at 
www.microsoft.com/technet. 

Single Sign-on (SSO) 
If you are using the Single Sign-on feature of Crystal Enterprise with Active 
Directory, modify the IIS authentication option for your web site to remove the 
Anonymous User. 

Steps to Remove Anonymous User: 
1. Open the Internet Services Manager by clicking Start > Programs > 

Administrative Tools > Internet Services Manager. 

2. Right-click the web site where the Crystal Viewer and 
CrystalReportViewers virtual directories are located. 

3. Click Properties > Directory Security > Edit. Unselect the Anonymous 
User check box and select the option for Integrated Windows 
Authentication. 

4. Stop the WCS service, click the Configuration tab and select the option to 
use Active Directory authentication. 

To use Active Directroy as your default authentication option with ePortfolio, 
you must alter the Crystal Server Page(CSP) code of that application.. Change 
the “defaultaut” variable in the Logon.csp file as follows: 

defaultaut = “secEnterprise” to defaultaut =  “secWinAD”. 
This CSP file is located at: 

c:\Program Files\Crystal Decisions\Web 
Content\Enterprise9\ePortfolio\en\logon.csp 

http://www.microsoft.com/technet/treeview/default.asp?url=/technet/prodtechnol/windowsserver2003/proddocs/entserver/FindLinks.asp
http://www.microsoft.com/technet
http://www.microsoft.com/technet/treeview/default.asp?url=/technet/prodtechnol/windowsserver2003/proddocs/entserver/sag_ADgroups_1intro.asp
http://www.microsoft.com/technet
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Common Considerations 

Scalability 
For detailed information on scalability testing with Crystal Enterprise, refer to 
the technical brief, ce_scalability_testing.pdf on our support site at: 

http://support.crystaldecisions.com/search 

Performance 
When logging into Crystal Enterprise is slower than expected, the graphing of 
mapped groups can affect the performance of Crystal Enterprise. 

Graphing of Mapped Groups within Crystal Enterprise 
Mapped groups are kept in a graph. This graph is held in a cache for 15 minutes 
from the time it has been built, after this the graph is deleted and regenerated. If 
the graph is currently in memory the login should be quick. When the graph has 
either expired or does not exist in memory, the first user to logon triggers the 
update of the graph. Alternatively, clicking the update button in the Active 
Direcotry Tab in the Authentication section of the Crystal Management Console 
will manually update the graph. 

If group membership changes in Active Directory, the changes will not be 
reflected either until the current graph expires and is recreated or until the 
update button is pressed from the Active Directory Tab in the Crystal 
Management Console. 

There is a registry key that can be either changed or disabled for the above 
mentioned graph. If the key exists already it will be set at 900000 milliseconds 
which is equal to 15 minutes. Please note that there is no hot fix or update 
necessary to use this key. 

If the key does not exist, it can be added at: 

HKLM/Software/Crystal Decisions/<version number>/Enterprise/Auth 
Plugins/secWinAD/ 

Name: GraphTimeOut 

Value: <string type> 

To disable this graph functionality set the key to zero (0) and the Active 
Directory plug-in will use an alternative method of calculating a user’s parents. 

It would only be advantageous to disable the graph if it has been determined that 
the time to build the graph takes significantly longer than the alternate method 
of calculating a user’s parents. If both methods are found to take a significant 
amount of time, it may be advantageous to set the timeout for a longer period 
and update the graph manually. 

Note that the time to build the graph in the Crystal Enterprise system is linearly 
proportional to the total number of groups mapped into the system. On the 
otherhand the time required to calculate a user’s parents is done on a user by 

http://support.crystaldecisions.com/communityCS/TechnicalPapers/ce_scalability_testing.pdf.asp
http://support.crystaldecisions.com/search
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user basis and can be rather unpredictable. For example, if a user belongs to 
many Active Directory groups, it may take a very long time regardless of 
whether the groups are mapped into Crystal Enterprise or not. 

Microsoft recommends that organizations deploying Active Directory have a 
global catalog server in each domain to speed up the processing of user logons 
and resource requests. The speed of authentication through Crystal Enterprise’s 
Active Directory plug-in will be related to this recommendation. 

Updates to the Active Directory Plug-in 
When there are updates to secWinAD.dll included in a Hot Fix, refer to the 
detailed instructions included in the technical brief, 
Hot_Fix_Application_Guide.pdf, on our support site at: 

http://support.crystaldecisions.com/search 

Contacting Crystal Decisions for Technical Support 
We recommend that you refer to the product documentation and that you visit 
our Technical Support web site for more resources.   

Self-serve Support: 
http://support.crystaldecisions.com/ 

Email Support: 
http://support.crystaldecisions.com/support/answers.asp  

Telephone Support: 
http://www.crystaldecisions.com/contact/support.asp 

 

 

 

http://support.crystaldecisions.com/communityCS/TechnicalPapers/hot_fix_application_guide.pdf.asp
http://support.crystaldecisions.com/search
http://support.crystaldecisions.com/
http://support.crystaldecisions.com/support/answers.asp
http://www.crystaldecisions.com/contact/support.asp
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