Prompt Values in Publication Not Changing

Hi,

I created a publication with two reports with prompts.

When I create a schedule with this publication, I can’t change the prompt values…

  1. When I changed it and click Apply, it seems to take it
  2. But when I come back to it, it reverts back to previous prompt values
  3. I also tried changing the prompt, save it, and directly schedule it. It does not work either.

Has anyone encountered this issue?

I am on Platform 4.2 Support Pack 3 Patch 6

Thanks in advance.


lwirjo (BOB member since 2003-02-01)

I’ve seen similar with a standard schedule. Did you try recreating the publication from scratch, ensuring that the reports are purged including prompt values and setting the prompts when scheduling the publication, not whilst creating the publication…if that makes sense?!


Nick Daniels :uk: (BOB member since 2002-08-15)

Hi Nick,

I did.

I tried recreating the publication from scratch (then adding reports, etc.)… Even in this case, I can’t change the prompt values. (It stays with the values the reports were saved on)

Changing prompt values on publication seems like a normal practice.

Thanks
Lionel


lwirjo (BOB member since 2003-02-01)

Delete the prompt from the report and re-add it.


Nick Daniels :uk: (BOB member since 2002-08-15)

Nick,

I just got a chance to work on it, and it worked.

I deleted the prompts, and added them back.

I can now change the prompt values on the publication.

Thank you!


lwirjo (BOB member since 2003-02-01)

That’s awesome…thanks for coming back to us 8)


Nick Daniels :uk: (BOB member since 2002-08-15)