CMS operation timed out

Through a custom application I am querying a lot of objects in the CMS repository and I have recently started to receive this error:

CMS operation timed out after 9 minutes.

If I reduce the amount of objects that I am querying it works fine.

I do not want to change my query, so is there a way to increase the time out from CMS?

Thanks,
-J


knowthediff (BOB member since 2005-12-06)

FYI, there is a registry hack to change the time out. We chose not to do this and altered our code instead to loop through the id’s but I thought I would post in case anyone elses wanted to know:

Increase the CMS Thread timeout:

  1. In the Windows Registry Editor, browse to the following sub key:

HKEY_LOCAL_MACHINE\SOFTWARE\Business Objects\Suite 11.0\CMS\Instances<machinename>.cms\ThreadTimeoutAfterNMinutes

  1. Double-click the ThreadTimeoutAfterNMinutes String Value.

  2. In the Value data text box, increase the number of minutes until it times out. Click OK.


knowthediff (BOB member since 2005-12-06)

Thanks for this Update. It helps me to run few quearies against CMS.


BOpat :us: (BOB member since 2006-11-09)

where???
i will find the windows registry editor?
Can anybody help me out for the exact location
Thanks in advance.


saifkhancs35 (BOB member since 2010-04-28)

Hi,

Login to the windows server
Click Start —> Run
Type Regedit

Then navigate the the directory…


jpchase (BOB member since 2011-07-25)

I assume something is wrong with your CMS if it needs 9 minutes to proceed a query…

Check KB 1448881 “Multiple instances spawned after daylight savings time change”


Dmytro Bukhantsov :norway: (BOB member since 2011-10-14)